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Requirements

¢ Installation of relevant CAD software, including but not limited to:

MicroStation 08.11.07 (V8i SS1)
MicroStation 08.11.09 (V8i SS3)
Power Inroads 08.11.07 (V8i SS2)
Power Inroads 08.11.09 (V8i SS4)

o O O O

e Installation of (just one!) appropriate ProjectWise Explorer client, including
but not limited to:

o ProjectWise Explorer 08.11.11 (V8i SS4)
o ProjectWise Explorer 10.00.02 (CONNECT)
o ProjectWise Explorer 10.00.03 (CONNECT)

e Installation of MDOT SHA Workspace 2.x.
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https://www.roads.maryland.gov/mdotsha/pages/Index.aspx?PageId=29

Overview

Successful use of MicroStation/CAD with ProjectWise for SHA projects requires two
things:

e iDesktop Integration
e MDOT SHA CAD Workspace Integration

InRoads SS2 and SS4 users may also like to review the section on ALG Access Control
for instructions on how to configure their software for a multi-user project
environment.

To be clear, the two main goals of iDesktop Integration and CAD Workspace
Integration will be achieved by closely following the instructions laid out in the
MDOT SHA's ProjectWise Installation Guide and the MDOT SHA CAD Workspace
Setup Instructions. No additional steps are needed.

This document is meant to provide supplemental information to explain and
address the most common problems encountered during setup.

iDesktop Integration is Bentley’s term for ensuring that your software, whether it
is a CAD application or Microsoft Office, is able to browse the ProjectWise
datasource (without using ProjectWise Explorer).

MDOT SHA does not typically enable integration for Microsoft Office products such
as Word or Excel. However, enabling iDesktop Integration for Bentley applications
is absolutely necessary for effective use of the software. Failure to do so not only
affects the ability to browse for DGN files in your project directory, but also
prevents the proper attachment and display of reference files.

MDOT SHA CAD Workspace Integration means that when you open a CAD file from
ProjectWise, the software loads the appropriate workspace resources, including
level libraries, custom lines styles, discipline-specific menus, etc. While the newer
“managed” workspace will be loaded automatically, older projects using the legacy
“workspace profile” may require some local configuration.
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https://www.roads.maryland.gov/ohd2/How%20to%20Install%20and%20Configure%20ProjectWise%20Explorer%20CONNECT.pdf
https://www.roads.maryland.gov/OHD2/ReadMe_Workspace_2.01.03.pdf
https://www.roads.maryland.gov/OHD2/ReadMe_Workspace_2.01.03.pdf

Enabling iDesktop Integration

It will be immediately evident whether a software is integrated with ProjectWise if,
when you select File > Open from within that application, a ProjectWise dialog box
appears instead of a Windows dialog box.

B4 Open et
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Folder

|~ Erosion and Sediment Control w| 4p L'-'_]
& [ Ml 2

Document

Mame File Size

Z L cAD
# | Project Management

' >

Address: |pu-.':‘n,‘nsha'umpln'x.shacadd.ad.mdot.mdsmte:SHAEDMSDz\Dnmments\SEndards and P ~ |
Description: | |
File Mame: | |
Application: &l Applications i
Extension: * dan;*.dwa;*. dxf i

] open document as read-only

=

&n Cancel

iDesktop Integration should be enabled at the time ProjectWise is installed. Note
the following screenshot adapted from page 2 of MDOT SHA's ProjectWise
Installation Guide:
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ProjectWise Explorer CONNECT Edition

Select feature to install

4 ProjectWise Explorer “
4 ProjectWise Explorer and Tools
ProjectWise 64-bit components

4 ProjectWise Explorer

+  Bentley Viewing, Printing and Markup
+ Messaging Services
+ Document Creation Wizard

4 MW iDesktop Integration

Bentley Application Base Integration
Bentley Application Base Integration (x64)
4 ProjectWise Integration for Microsoft Office 2016 and 365
Microsoft Word
Microsoft Excel
Microsoft PowerPoint

Provides integration support for Bentley desktop applications and alse third-party desktcp
applications.

Size: 39.8 MB

If iDesktop Integration was not enabled at the time of installation, or if the CAD
software was installed after ProjectWise, it may be necessary to Change the
installation options via Control Panel > Programs and Features (to ensure that
IDesktop Integration is turned on). In some cases it may be necessary to uninstall
and re-install the ProjectWise Explorer client.
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Disabling ProjectWise Login Popup

One of the consequences of enabling iDesktop Integration is the ProjectWise login
that appears when you first load the software from a desktop shortcut:

Password: | |

Please wait while detecting available datasources...

Most users do not want to see the ProjectWise login popup when they are not
actually using ProjectWise. Therefore, the MDOT SHA Workspace automatically
disables this popup. The relevant configuration is contained in the mcm.user.cfg
file:

Disable ProjectWise Integration unless the ProjectWise V8i Explorer
client is being used. i.e., the user won't be prompted to login to PWise

P

$1if !defined (_PWEXPLORER)
PW DISABLE INTEGRATION = 1
$endif

Again, users need only follow the standard MDOT SHA Workspace Setup
Instructions in order to implement this.

Note that this configuration will continue to work for consultants whether or not
they are using the MDOT SHA Workspace. For those who prefer to retain the login
popup, “comment out” the three lines shown above by prepending each line with
the “#” character:

# $if !defined ( PWEXPLORER)
# PW_DISABLE INTEGRATION = 1
# %Sendif
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https://www.roads.maryland.gov/OHD2/ReadMe_Workspace_2.01.03.pdf

Enabling MDOT SHA CAD Workspace Integration

Workspace integration is necessary to check out and work on CAD files that are not
governed by the Managed Workspace. Such projects are configured in ProjectWise
as follows:

Folder Properties *
General Spatial Statistics Wordlow & State Work AreaFolder Security
Document Security WView Audit Trail Work Space
Work Space type: Work Space Profile e
‘WarkSpace Profile: MDOSHA_VE_01 w
Property Value 2

EE MName MDSHA_V8_01
EH Description 2004 CAD Standards
BB microstatinn-snecific set..

MDOT SHA’s workspace profiles utilize the following command line switch:
-ws_MDOT_STANDARDNAME=SHA_V8 01

This variable (_ MDOT_STANDARDNAME) is used as a hook to load your local MDOT
SHA workspace when a CAD file is opened through ProjectWise. The relevant
configuration is found in the mcm.user.cfg file delivered with the MDOT SHA
Workspace.

Note that the standard setup instructions for MDOT SHA Workspace 2.x
automatically enable integration of your CAD workspace with MDOT SHA’s
ProjectWise datasource. No additional configuration is needed. Be sure to follow
the instructions for ProjectWise users on pages 4 and 5.
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UCF Not Found Error

The most common integration error occurs when users try to open a DGN file
from ProjectWise Explorer and receive the following error message (or slight
variation):

E, Power InRoads V8i (SELECTseries 4) - Text Window — O

ict not found,
\PowerInRoadsh\cont

ProjectWise has failed to locate the workspace root directory. This is a clear sign
that the workspace is not properly integrated. Please review the workspace setup
instructions, paying particular attention to the variable named
_MDOT_WORKSPACEROOT.

If necessary, generate a debug file and send it to SHA CAD support.
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Requesting Support and Generating a Debug File

If necessary, generate a debug file to share with SHA’s CAD support staff, as
follows:

e Right-click the ProjectWise DGN file and select Open With...

23 Open decument with *
Select

Program

MName Description Application

Mt Covier InRoads V8i (SELECTseries 4) Power InRoads 554 "C:\Program Files (x36)'Bentey\PowerInRoa
EJ OpenRoads Designer COMMECT Edition "C:\Program Files\Bentley\OpenRoads Desigr
,‘aMichStah'an PowerDraft COMMECT Editio "C:\Program Files'\Bentley WMicroStation Powe
. ‘Power InRoads V8i (SELECTseries 4) "C:\Program Files (x8a6)\Bentley\PowerInRoa

g R "C:\Program Files\Bentley\MicroStation Powe

>

[J always use this program Browse

Open document as read-only

Cancel

e Select the option that has “zzz_DEBUG” in the Description.

e Uncheck the option to “Always use this program” (UN-check!)
e Check the option to “Open document as read-only”

e Click OK.

A message window will appear with scrolling text. When the scrolling ends, the last
line of the message will indicate the path location of the newly generated debug
file. (If the debug process is interrupted before displaying the output path, search
for a file named msdebug.txt it in your local User directory:

C:\Users\[username]\AppData\Local\Temp\msdebug.txt

Locate this file and send it as an email attachment to ids@mdot.state.md.us along
with a brief explanation of your problem.
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InNRoads SS2 and SS4 ProjectWise Integration

Working with ALG files within ProjectWise is different from working with ALG files
on a shared network drive. This is because ProjectWise copies files to a temporary
local location. Additional steps are required to establish Access Control for a shared
ALG file in a multi-user project environment.

*These instructions apply to the SS2 and SS4 versions of InRoads, and most likely
the SS10 version (similar to SS4 but with CONNECT rather than SELECT licensing).

MDOT SHA does not support InRoads SS3.
InRoads ALG File: Access Control

While working on a shared network drive, Access Control allows users to share a
single ALG file among a group of users. InRoads uses Read-Write and Read-Only
flags to keep track of which alignments (and the Cogo buffer) are being edited by
which, thus preventing conflicts and accidental overwrites. A special interface is
provided to exchange access control between users accessing the ALG file.

To open the Access Control Detail dialog box, right-click on the Geometry Project
name in the InRoads Explorer (either pane), and in the context menu that opens,
select Details.

File Suface Geometry Drainage Evaluastion Modeler Drafting Quantties Tools Help
| <Unnamed> -BE (877 B B E
Name Description By Whom Last Revised Access Mede Style
=55 Geometry Projects S Cemetery A... cgmecall 02/26/2014 4:0... Read-Only BLIM

&L= Default %% Cogo Buffer crheault 03/23/20181:2.. Read-Write

w Mew... cgmecall 01/29/20137:5... Read-Only Default
cgmecall 05/10/201212:... Read-Only Default
Save cgmecall 10/04/201311:... Read-Only Default
% e — i Save As... ___rcamerall 02/21/201311:..  Read-COnhe Defanlt

Set Active

Copy...

Close

Empty
View All Horizontals
View All Turnouts
View All Rails, Joints and Distance Keepers
Fit
Details... l}
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After selecting this menu item, the Access Controls Details dialog box will open.

Type
Cogo Buffer
Horizontal
Horizontal
Horizontal
Horzontal
Horizontal
Horizontal

Horizantal

[ E———

Mame Locked By User

Cogo Buffer crheault
Mew IC Entrance crheault
Cemetery Access

developer centerine

diversion ditch

Emigo median nose

ex-contee-LT

ex-contee-RT

LY RN  FN |

Iy Access

Read-Write
Read-Write
Read-Only
Read-Only
Read-Only
Read-Only
Read-Only
Read-Only

[ T 7, W

Last Revised

03/23/2018 12319 FM
12/19/2013 11:35:05 AM
02/26/2014 4:02:27 FM
01/29/2013 7:56:08 AM
05/10/2012 12:19:50 PM
1070472013 11:11:24 AM
02/21/2013 11:43:14 AM
02,21/2013 11:36:53 AM

M AN N A Cn.an Nk

4|

This dialog box has a selection list box and a row of buttons on the right-hand side
of the dialog box. In the image shown, the Cogo Buffer and one Horizontal
(alignment) are set to Read-Write Access and are shown as Locked By (a) User.
Additionally, the Horizontal (alighment) is selected which enables all buttons,
except for Check Out, since the alignment is already checked out.

There is a version of this dialog box that works in a very similar manner outside of
ProjectWise, but to get the proper function within ProjectWise, several additional
steps are necessary.
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Enable “Geometry — Alternate Workflow with ProjectWise” via Variable Manager

The following steps must be performed for any user that will be sharing access to
ALG files. On the InRoads Explorer, select Tools » Variable Manager. This will open
the following dialog box.

:l [Cymamic Update of Design Graphics

:lGenemI - Disable Regional Settings for all InRoads products
Command Behavior:

E aeometry - Atemate Wordlow with ProjectWise

[<]File - Persist Project Default Paths

[ |File - Omit Project Options Full Path

[ |File - Enable History Logging

T [ S | g E I D [ N ) RN NN QU o [SOUEpE PRSI s Duprp

Description

Enables the software to manage the access to alg files diferently in a ProjectWise
environment. The software will automatically check-out and check-in the alg file. The user
should consult the ProjectWise and Plotting Integration pdf document for details.

Scroll down to the Command Behavior: group and check on the Geometry —
Alternate Workflow with ProjectWise. Press the Apply and Close buttons.

With this accomplished, ProjectWise and InRoads are now set to manage the
Access Control of ALG file for multiple Users.
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Lastly, Bentley recommends changing the default settings for how InRoads opens
ALG files. For this to work as intended, you must be in a Preference (XIN) file with

Read-Write Access.

On the InRoads Explorer, select
File » Options » Geometry and in
the Project Options dialog box,
select the Geometry tab.

At the bottom of that tab, change
the Default Access Mode for
Horizontal Alignments and Cogo
Buffer to Read-Only.

Press the Apply button.

Next press the Preferences
button. When the Preferences
dialog box opens, press its Save
and then its Close button. This will
save the Default Preference that
loads when InRoads is launched.

To complete the process, press
the Close button on the Project
Options dialog box.
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Additional Notes

InRoads uses the users Windows ID if possible, otherwise it defaults to the
ProjectWise ID. When using the ProjectWise ID, inconsistent use of case in the ID
may cause issues. For example, if a user connects to ProjectWise using all lower-
case character in their ID and checks out an alignment, InRoads sees that users
name as being all lower-case. If they save and exit without freeing the alignment
and later log in to ProjectWise using a mixed case (or all upper case) ID, InRoads
will see that user as a different user. As a result, that user will not automatically
gain read-write access to that alignment.

In order to take ownership of that alignment, that user has two choices. They can
log back out of ProjectWise and log back in using the same case as they originally
logged in, of they can use the “universal” free command that Bentley built into
InRoads when they changed how the ALG file manages Access Control. To free any
alignment no matter who the user is, the user can hold down the Ctrl key while
selecting the Free command.

If the user has read-write access to an alignment and saves the ALG but does not
free the alignment, it remains checked out. This command behavior will frequently
result in alignments being locked by a user when they are no longer in InRoads or
even ProjectWise. It is therefore very important that users be made aware of this
command behavior, but more importantly, how the Ctrl+Free command can free
any locked alignment.

Some methods of loading other InRoads support files can result in them being
Copied Out and not Checked Out of ProjectWise. This may result in users making
edits to the local copy of the file but not being prompted to check them back in and
even leaving them unable to push their changes back to ProjectWise. Additionally,
if other users have checked out, edited and then checked in one of these files,
should another user update the file with a different version, the other users’ edits
will be lost.

It is therefore recommended that users verify that files are either checked out or
opened read-only before deciding to begin making edits. If the file to be edited is
not checked out, a user should manually check it out and then, any edits they make
will be saved to the checked-out copy and other users will be unable to check out
the document.
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It is also recommended that users open the local document organizer whenever
they exit an InRoads session to confirm that all checked out files are checked in or
at the very least, the server copy has been updated.
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